JDotter Documentation


Main Help Page

 

Getting to know JDotter

A brief introduction into the usage of JDotter and its main windows and tables.

Introduction

Java-Dotter (JDotter) is a platform-independent Java interactive interface for the Linux version of Dotter – a widely used program for generating dotplots of large DNA or protein sequences. JDotter runs as a client-server application and can send new sequences to the Dotter program for alignment as well as rapidly access a repository of preprocessed dotplots. JDotter also interfaces with a sequence database or file system to display supplementary feature data. Thus, JDotter greatly simplifies access to dotplot data in laboratories that deal with large numbers of genomes and have a multi-platform organization.

Mac-users:

The default DASHBOARD settings use the middle mouse button; you need to change this in the DASHBOARD preferences to be able to use this button for zooming JDotter plots.

For more information on Dotter, please refer to the published paper: Gene. 1995 Dec 29;167(1-2):GC1-10. A dot-matrix program with dynamic threshold control suited for genomic DNA and protein sequence analysis. Sonnhammer EL, Durbin R.

The Main JDotter Window

The components of JDotter’s main window

picture

This is the main JDotter window. From this window, you may open preprocessed dot plots stored on your local system or the VOCS application server, or input new sequences to be plotted. The main window is composed of 3 parts:

  1. The Menu bar
  2. The “Horizontal Sequence” panel
  3. The “Vertical Sequence” panel

The Menu bar

The JDotter menu bar can help you load files and set preferences as well as providing information about the program.

The File menu

JDotter File Menu

From the file menu, you have the ability to:

  • Open pre-existing, locally stored Dotter or JDotter plots
  • Open pre-processed VOCS JDotter plots
  • Set user interface and dot plot preferences
  • Check the application server status (host name, maximum query length)
  • Quit

The Help menu

JDotter File Menu

Using the Help menu, you can obtain the following:

  • Information about the JDotter program
  • Link to online help pages (this manual)

The Horizontal Sequence Window

picture

For the sequence you wish to plot horizontally, start here by entering a name in the “Name” field (e.g. “horizontal 1”). Input the corresponding sequence into the sequence window immediately below, either by clicking on the “import” button and selecting the file or by pasting the sequence into the window. Now you can click “Add>>” to transfer the sequence to the list on the right-hand side of the window. Selecting a sequence from the list and clicking “<” will delete it from the list.

The Vertical Sequence Window

picture

To add sequences to be plotted vertically on the graph, apply the instructions for “The Horizontal Sequence Window” above to the analogous fields of the vertical sequence window. Enter a different name in the vertical sequence “name” field for this sequence.

When you have finished entering at least one horizontal and one vertical sequence, click on “run dot plot“. If desired, you can enter multiple sequences to be plotted both horizontally and vertically. Each of the horizontal sequences will be plotted against each of the vertical sequences. Therefore, entering three horizontal and three vertical sequences will yield 3 x 3, or 9 dot plots in total.

 

The Dot Plot Window

The components of JDotter’s dot plot window

picture

From the main dot plot window, you can navigate the dot plot, change the grey scale indexing, view the plotted sequences and zoom into regions of interest within the plot. Only one dot plot window per JDotter session may be open at a time; however, you may load data from the main JDotter window as many times as you like. The most recently loaded data will replace the data currently in the display.

The Dot Plot Results Window

Clicking on any point in the plot will center the crosshairs at this location. To move the crosshairs manually, use the arrow keys or click and drag with your mouse. The “←” and “→” keys of your keyboard will move the crosshair left and right (respectively) within the plot; similarly the up-arrow and down-arrow keys of your keyboard will move the crosshair up and down (respectively) within the plot.

In the example shown above, the area of the plot appears almost entirely gray except for a faint black line running from the top left corner to the bottom right corner of the plot. This line indicates a strong degree of alignment between the two sequences at the positions where it occurs. This is the most predominant line on the plot, however, by adjusting the contrast settings with the GreyMap Tool, it is possible to visualize other regions of similarity between the two sequences. For example, suppose the line begins at (25, 13) and runs along the diagonal to (39, 27). This would indicate matches between nucleotides 25 & 13, 26 & 14, 27 & 15 and so on until nucleotides 39 & 27 of the horizontally and vertically plotted viruses.

To select a feature, simply click on the bar that represents it at the top. If you select both a feature from the top and one from the left-hand side, the area at which they intersect will be selected with a red zoom rectangle.

picture

If the sequences contain annotated features (ie. genes of a whole-genome sequence loaded from the VOCs database) they will be displayed along the top and left-hand side of the plot. Features are displayed in red if they represent regions on the top strand of DNA and blue if they exist on the bottom. Labels are written in black, but are only present if there is room on the screen to fit them.

The Menu Bar

The menu bar is used to manipulate the windows, data views, file saving format etc. of the JDotter session within which you are working.

The File Menu

From here you can open, save (with extensions .jpg or .jdt) or print a plot. You can also close the JDotter session from the file menu.

The View Menu

Using this menu, you have the ability to:

  • view the scoring matrix used to prepare the dot plot
  • move the crosshair to a specific location in the plot by selecting “go to location…“. In the window that pops up, type in the numerical horizontal and vertical location to which you would like to move the crosshair
  • go to the location of a specific feature in the plot. To do so, select “Go To Feature…“. A dialog will appear showing two lists; the list in the left-hand window represents features that belong to the sequence plotted horizontally while the list on the right represents those belonging to the sequence plotted vertically. The features listed are limited to those that are currently visible in the dot plot window. If you have zoomed in, you may lose some of the features from this list. To see all features for both sequences, select “zoom original” from this menu and the display will reset to the original view of the Dot Plot.
  • use a number of zoom features: to zoom into a selected area either select the area

The Alignment Tool

This window displays the horizontal and vertical sequences aligned at the position currently centered in the cross-hair. For instance, If the crosshairs are at (80, 44), then the alignment tool will show the horizontal sequence’s 80th nucleotide aligned with the vertical sequence’s 44th nucleotide, as well as the flanking nucleotides.

The GreyMap Tool

Plot shading can be adjusted with the GrayMap Tool. This allows you to increase or decrease the degree of contrast to better visualize features of the plot.

 

JDotter Tutorials

Tutorials on how to get the most out of JDotter

How to open a dot plot from the VOCS database

picture

From the main JDotter window, select the File menu item. Choose Open Remote Plot…. This will bring up a dialog box with two lists of names, representing the available whole-genome sequences in the VOCS database. Select one sequence to display on the horizontal axis and one to display on the vertical axis. The drop-down menus above the list allow you to switch to a different viral family database and change between name or abbreviation viewing preferences. After you have made your selections, click Open to send the request to the server. Once the dot plot has been retrieved, the Dot Plot Window will open with the selection displayed.

How to send a list of sequences to be plotted

picture

To build a list of sequences to send to the application server to be processed, you may add them one by one into the list by entering a name and a sequence and clicking Add >>.

picture

When you click Add >> to add a sequence, the fields will be cleared and the sequence name will be added to the list of sequences to run. You may remove names by selecting them from the list and clicking << Remove.

How to load sequences from a file

In addition to adding sequences one at a time, you can import one or more sequences from a FASTA file. Click Import… in the relevant sequence panel (horizontal or vertical.) A file dialog will pop up allowing you to select a file from one of your local folders. The sequence(s) will be loaded directly into the list just as though you had added them one by one into the entry fields provided.

picture

If the import is successful, this dialog will pop up to let you know the sequences have been added. (No message will appear for an unsuccessful import.)

How to select a region and zoom in to it

There are two ways to select a region of the dot plot:

  1. Click once with the middle mouse button and drag the red box to the size and shape you want, then double-click (again with the middle button.)
  2. (Mac users) Hold down either ALT or the Apple key; click with the left mouse button, drag the box to cover the region, then release the left mouse button.

To zoom in to this region, select Zoom Selection from the View menu.

How to view your submission

From the main JDotter window, click on View Sequences (beneath the horizontal or vertical sequence list.) This will open the sequence submission window.

picture

From here you can view the sequences currently added for submission. You may also remove sequences by selecting them in the list and clicking Remove, or remove all sequences to clear the list by clicking Remove All. Click Close to return to the main JDotter window.

How to navigate the dot plot

Left-click on a position in the dot plot to move the crosshairs to that point. The sequence positions represented by the crosshairs are displayed offset from the crosshairs themselves. (These coordinates represent the sequence positions on the displayed map, not the pixel coordinates on the screen.)

You can also use the keyboard to navigate as follows:

Key Movement
Left Arrow Move Left
Right Arrow Move Right
Up Arrow Move Up
Down Arrow Move Down
> or . Move Down & Right
< or , Move Up & Left
{ or [ Move Down & Left
} or ] Move Up & Right

How to move to/zoom in to a specific region from the menu

To go to a specific position on the dot plot without manually moving the crosshairs, select Go To Location… from the View menu. Here, you can enter the specific x and y coordinates you would like to move the crosshairs to.

To zoom to a specific region in the same way, select Zoom To… from the View menu and enter the specific beginning and ending coordinates on the x and y axes of the region that you would like to zoom into. (These coordinates represent the sequence positions on the displayed map, not the pixel coordinates on the screen.)

To zoom back out to the original view of the data, select Zoom Original from the View menu. This will reload the original dot plot.

How to use the sequence alignment tool

The Alignment Tool displays, for each sequence, the immediate region surrounding the point indicated by the crosshairs in the Dot Plot Window. The two sequences in the window will be shown as aligned at this point (e.g. if the crosshairs are located at (65, 80) then nucleotide 65 in sequence X will be paired with nucleotide 80 in sequence Y, 66 with 81, 64 with 79, and so forth.) In other words, the alignment seen in this window represents a 45-degree diagonal line (running upper left to lower right) drawn through the selected point.

If the dot plot represents a DNA-DNA matrix, the horizontal strand will be compared to the vertical in both forward and reverse complement ordering. For proteins, exact character matches are coloured with a light cyan while positive non-matching hits are coloured in a deeper blue.

To move the alignment tool view, drag the scrollbars displayed above and below in the tool. The top scrollbar represents the location along the horizontal axis, while the bottom scrollbar represents the location along the vertical axis. You will notice that as the scrollbar positions are changed, the crosshairs in the Dot Plot Window also move, and visa versa. To move along the alignment currently in the window (in other words, to move along the diagonal) use the < and > buttons.

How to view local Dotter (.dot) files in JDotter

How to guide to viewing Dotter files in JDotter.

Before opening (.dot) files in JDotter, it is important to know what hardware architecture they were created under: “Big-Endian” or “Little-Endian”.

The adjectives big-endian and little-endian refer to which bytes are most significant in multi-byte data types and describe the order in which a sequence of bytes is stored in a computer’s memory.

In a big-endian system, the most significant value in the sequence is stored at the lowest storage address (i.e., first). In a little-endian system, the least significant value in the sequence is stored first.

Many mainframe computers, particularly IBM mainframes, use a big-endian architecture. Most modern computers, including PCs, use the little-endian system. The PowerPC system is bi-endian because it can understand both systems.

Converting data between the two systems is sometimes referred to as the NUXI problem. Imagine the word UNIX stored in two 2-byte words. In a Big-Endian systems, it would be stored as UNIX. In a little-endian system, it would be stored as NUXI.

Opening Dotter (.dot) files in JDotter:

1) Select File/Preference/User Interface/ in the main JDotter window.
2) In the JDotter Preferences window that opens, choose either the Little-Endian or Big-Endian radio button depending on how your file was created.
3) Click the “Apply” button to apply changes
4) Select File/Open Local Plot…/Dotter (.dot)/ in the main JDotter window.
5) Enter the Horizontal, Vertical, and Dot Plot files in the respective boxes
6) Click the “Run Dot Plot” button to view the plot (Note: If you get an error, it could mean that your file was created under a different architecture. Go back to step 2 and switch the .dot file type)

 

References

Published Papers

Brodie R, Roper RL, Upton C. (2004). JDotter: a Java interface to multiple dotplots generated by dotter. Bioinformatics. 20(22); 279-281.

Ehlers,A., Osborne,J., Slack,S., Roper,R.L. and Upton,C. (2002) Poxvirus Orthologous Clusters (POCs). Bioinformatics, 18, 1544-1545.

Junier,T. and Pagni,M. (2000) Dotlet: diagonal plots in a web browser. Bioinformatics, 16, 178-179.

Sonnhammer,E.L. and Durbin,R. (1995) A dot-matrix program with dynamic threshold control suited for genomic DNA and protein sequence analysis. Gene, 167, GC1-GC10.

Upton,C., Slack,S., Hunter,A.L., Ehlers,A. and Roper,R.L. (2003) Poxvirus orthologous clusters: toward defining the minimum essential poxvirus genome. J. Virol. 7590-7600.

Tagged with:
 

Comments are closed.